Skip to end of metadata
Go to start of metadata

Dependencies and Download

TDI library depends on jQuery. The minimum supported version of jQuery is 1.10.2 (see issues TDI#8 and jQuery#13936).

TDI can be downloaded in two different ways:

Setup

Now include both jQuery and TDI scripts to your page. Just remember, in case you already have jQuery included, that the minimum supported version of jQuery is 1.7.

TDI Initialization

Basic Usage

Please note this is only a very brief sketch that supposes you already know how TDI works. For more informative introduction to TDI, you may read our Tutorial.

 

1. Mark the HTML element, which is supposed to be serviced by TDI, by "tdi" CSS class:

2. As a response to the request, send instructions from the server on what should be done with the current page:

  • No labels